About FearCond

 Top Next

Purpose

Fear conditioning (shock US).

Software requirements

Requires Whisker v2.0 or greater.

Data storage

Text-based output to disk.

Author

Rudolf Cardinal (rudolf@pobox.com).

Copyright

Copyright © Cambridge University Technical Services Ltd


Required devices

 Top Previous Next

The program requires to claim devices in groups named box0, box1, box2… with device names as follows:

CSLIGHT                // output

HOUSELIGHT                // output

CLICKER                // output

TONE                        // output

SHOCK                // dangerous output

Please ensure that these devices are available and listed in the device definition file in use by the server.


Using the task

 Top Previous Next

When you run the task, you will see the following warning. Read and acknowledge it:

The main screen looks as follows:

You must connect to a Whisker server, claim an operant chamber (box), and set up the parameters for your task. Once that's done, the traffic lights will turn amber. When you are ready, press Start to begin the task.


Parameters

 Top Previous

The parameters dialogue box looks like this: